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What Is MWS Dialog Builder? 

APPLE® MWS DIALOG BUILDERTll is a MacWorkStationTll utility that allows 

developers to easily create dialog boxes for use with MacWorkStation 

applications. You can add the dialog boxes to local documents or transfer the 

command descriptions to the client application, which will send these 

commands to the Macintosh® computer to draw the dialog box at the 

appropriate time. This preliminary note introduces Dialog Builder, discusses 

dialog boxes and their usage, and details how to use Dialog Builder to create 

dialog boxes for your MacWorkStation applications. 

Dialog Builder greatly reduces the amount of time previously needed for 

constructing dialog boxes and also allows you to easily edit existing dialog 

boxes. MacWorkStation requires the resources DICL, Dm, and DLOG to 

create a dialog box, and Dialog Builder automatically creates these resources 

when you use it to build dialog boxes. Dialog Builder can also work with MWS 

Event Handler111• Event Handler is an application that associates "scripts• of 

MacWorkStation commands with MacWorkStation events, for example 

choosing a menu item or clicking a button in a dialog box. Whenever the 

MacWorkStation event is generated, its script is played, running the 

appropriate commands. MacWorkStation and Dialog Builder, along with 

Event Handler, complement the development tools available for prototyping 

and building applications. 
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What are dialog boxes? 

Dialog boxes are an integral part of the Apple Desktop Interface. Dialog boxes offer an easy-to­
understand way for an application to request data from the user. For example, a dialog box can 
present choices to the user or request information from the user. The user can enter several items at 
one time then dismiss the dialog box so that processing can begin. In contrast, a command sele.cted 
from a menu performs only one immediate action. Dialog boxes are also used to warn or alert the 
user about some potential problem. 

Dialog boxes can be modal or modeless, and Dialog Builder allows you to specify this when you 
create each dialog box. A modal dialog box is one that the user must dismiss before doing anything 
else (see Figure 1-1). 

• Figure 1-1 Modal dialog box 
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A modeless dialog box allows the user to perform other operations without dismissing the dialog 
box (see Ftgure 1-2). 
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• Figure 1-2 Modeless dialog box 
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Your application should have the same "look and feel" as other Macintosh applications so that users 
can understand how to use it with minimal instruction. Although Dialog Builder allows you to 
create dialog boxes with any combination of buttons, text, lists, and icons, you should be familiar 
with the standard usage of these items within Macintosh applications so that your application's 
features are most accessible to users. Your applications should follow the established, successful 
guidelines for dialog boxes and their elements. Refer to the Apple publication Human Interface 
Guidelines: 1he Apple Desktop Inter/ace for detailed discussions on the philosophy, design, and use 
of the elements of the Desktop Interface. 

Using Dialog Builder 

Dialog Builder contains a palette window of item.5 you can import to your dialog box. You issue 
commands using one of four menus, which permit familiar actions like Save and Quit, as well as 
functions to manage items in the dialog box. 

The palette window 

When you create or edit a dialog box, the Dialog Builder palette window will appear (see Figure 1-3). 
The palette window contains template items for buttons, icons, check boxes, radio buttons, static 
text elements, edit text elements, lines, pictures, user items, and scrolling lists. You can move the 
palette window anywhere on the screen by dragging it by the gray title bar. 
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• Figure 1-3 The Dialog Builder palette window 
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You can import any of the palette window's items to your dialog box simply by dragging the item 
from the palette window into the dialog box. Once an item is placed in the dialog box, you can 
reposition it, edit it, or set attributes to define it more specifically. You can edit the item by 
selecting it and typing in the new text or by double-clicking it and editing the text in its attributes 
window. To delete an item, select it and press the Delete key. 

As an item is created in the dialog box, Dialog Builder assigns it an item number, which is simply 
an identifier. By default, the number assigned is one digit higher than that d the highest numbered 
item already in the dialog box, although you can reorder them in any manner. You can also group, or 
duster, items as well as uncluster them. Optionally, you can have the state of one item govern the 
active state of a cluster; the item oversees the cluster. For example, the user may need to fdl in a text 
field before a button becomes active. 

The palette window displays the item and group (cluster) number of the currently selected 
item. If multiple items are selected, or the multiple items do not belong to the same group, then a 
dot ( •) is displayed instead of a number (see Figure 1-4). 

• Figure 1-4 Item and group numbers appear in the palette window 

Buttons 

Buttons cause some action to occur immediately after the user clicks them. In dialog boxes, two 
commonly used buttom are OK and Cancel. You may resize a button by dragging one of its handles. 
A button's attributes.include its text display, whether it appears as active or inactive (dimmed), and 
the cluster it belongs to (see Figure 1-5). Another button attribute, Check, causes MacWorkStation 
to check any formatted editable text fields for valid contents when the user clicks the button. By 
default, buttons are active but not checked. 
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• Figure 1-5 Button attributes 
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Icons in dialog boxes call the users attention to some problem, generally when continuing an action 
might have undesirable results. Applications use three types of icons for alerting purposes-Note, 
Caution, and Stop-the latter indicating the most severe problem. You may create a custom icon 
using a resource editor such as ResEdit™. 

The icon attribute choices are Stop, Note, Caution, or custom (see Figure 1-6). Custom icons are 
identified by icon number ID (ICN# ID). You can browse through the available custom icons by 
clicking the left and right arrows in the Icon Specifications dialog box. Icons are active (default) or 
inactive and can also belong to a cluster. When the Check attribute is selected, any formatted 
editable text fields are checked for validity when the user clicks the active icon. 

• Figure 1-6 Icon attributes 
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When you select a custom icon in the dialog box and double-dick, the custom icon appears in the 
attributes window. Double-clicking on the custom icon in the attributes window brings up 
another dialog box with the custom icon enlarged. Here, you can edit the custom icon and save it 
for use in the dialog box. 
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Check boxes and radio buttons 

Check boxes and radio buttons function similarly in that both give the user several options to 
choose from and both act as toggles between two states, on and off. 1be primary difference 
between them is that radio buttons are mutually exclusive. At any given time, only one radio 
button in a cluster is on, and turning on a radio button turns off the radio button that was on 
previously. Because check boxes are independent, the user can click any combination of them. 

A check box's or radio button's attributes are the text display, whether it appears as active or 
inactive, its cluster number, and the number of a cluster it oversees (see Figure 1-"/J. Optionally, the 
Report attribute causes MacWorkStation to send an event to the host when the user changes the 
radio button or check box. 

• Figure 1-7 Check box and radio button attributes 
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+ Note: The initial value of a check box or radio button is not a saveable attribute with 
MacWorkStation 3.0. 

Static text and edit text fields 

Static text is informational only; the user cannot change the text in any way. It is most often used 
to title items or clusters in a dialog box. A static text field can be used for messaging purposes. In 
this case, the host application changes the text in the static text field based on the status of the 
application. Or, depending on the application, some users may be allowed to change a text field 
while others may only view it 

You can resize the static text field by dragging its handles. Its text display is the static text 
field's only attribute (see Figure 1-8). 
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• Figure 1-8 Static text attributes 
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Edit text items receive and display information typed by the user, such as names and passwords. 
You can resize edit text fields by dragging their handles. Edit text attributes indicate whether the 
field is alphanumeric (default) or protected, meaning that asterisks are displayed as the user types 
(see Figure 1-9). Other attributes indicate if the field is required, the number of the cluster the field 
oversees, and the default text display. 

The fields Format 1 and Format 2 are used for validation. If the field type is alphanumeric, 
Format 1 and Format 2 give the valid ASCII range of the edit field. For protected field types, the 
text typed in by the user is matched against Format 1, and Format 2 is unused. 

• Figure 1-9 Edit text attributes 
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Lines are decorative, and you can use them anywhere in the dialog box. By default, dragging the line 
item from the palette window into the dialog box produces a horizontal line. You can resize lines by 
dragging the handles on either end. Lines do not have attributes, but they may belong to a cluster. 
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Pictures 

You can bring pictures into the dialog box simply by pasting them from the Scrapbook. A picture 
acts much like a button, performing some action when the user clicks it. You can resize pictures by 
dragging the handles. A picture's attributes include whether it is active (default) or inactive, its 
cluster number, and its resource ID (see Figure 1-10). The Check attribute indicates whether 
MacWorkStation should check any editable text fields for validity. 

• Figure 1-10 Picture attributes 
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A user item is a custom control item that may be designed and coded by you to suit the needs of 
your application. Control items typically can be set within a range of values, much like a switch or 
dial. The control is set up with minimum, maximum, and initial values. Within a dialog box, the user 
item acts as a placeholder for your custom control item. 

To use a custom control, you must first create it on your Macintosh computer and save it as a 
resource of a MacWorkStation document. Only then can you add the custom control item to a 
dialog box. 

The custom control item attributes include the title and whether the control is active (see 
Figure 1-11). Report indicates whether to generate an event when the user clicks the control. The 
initial, minimum, and maximum values detennine· the control parameters. RsrcID is the control 
item's resource ID. Cluster and oversee give the item's cluster number and the number of the 
cluster the control item oversees. 
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• Figure 1-11 User item attributes 
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Scrolling lists present the user with a number of text items to choose from. A common example of 
this is the scrolling list that appears after choosing the Open command from the File menu. When 
you drag the scrolling list item from the palette to the dialog box, sample items are displayed in the 
scrolling list to help you judge the size of the box you want to use. You can resize the scrolling list 
box by dragging its handles, and the number of items in the list is adjusted according to the box 
size. 

Scrolling list attributes include its cluster number, whether the user is allowed to double-click an 
item in the list to select it, and whether multiple selections within the list are permitted (see Figure 
1-12). 

• Figure 1-12 Sgolling list attributes 
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The menus 

Dialog Builder consists of four menus: the standard Apple, File, and Edit menus, plus an Options 
menu. The Apple menu brings up all your available desk accessories as well as an •About Dialog 
Builder" menu. The Edit and File menus offer standard operations as well as some file and edit 
functions specific to Dialog Builder. The Options menu contains most of the item manipulation 
commands unique to Dialog Builder. 

The File menu 

The File menu brings up the dialog box ftle manipulation commands Open, OCR, Save, and Report, 
as well as the Quit command used to quit Dialog Builder (see Figure 1-13). 

• Figure 1-13 The File menu 
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To create a new dialog box or edit an existing one, choose the Open command to bring up a scrolling 
list from which you select the MacWorkStation document in which you want to work. After you 
choose the document, another dialog box appears listing all the dialog boxes currently in that 
document (see Figure 1-14). You may view the list by name or by resource ID. 
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• Figure 1-14 Opening a dialog box in an application 
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At this point, you can modify or remove an existing dialog box or add a new dialog box. If you 
select Modify, the dialog box will appear for you to edit. If you select Add, a Dialog Window Type 
box appears along with an empty dialog box window for you to begin creating the new dialog box 
(see Figure 1-15>. 

• Figure 1-15 Dialog Window Type box 
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From within the Dialog Window Type box, you can select the type of window that will be 
displayed. You type the window's title, resource name, and resource ID, and set the dialog box to be 
visible or not visible and modal or modeless. The resource ID must be a number between 1 and 
29,999; all others are reserved for MacWorkStation or the System. (You can also select Cancel, create 
the dialog box, then save it and bring up the Dialog Window Type box again, entering this 
information later.) 
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After dismissing the Dialog Window Type box, you can create the new dialog box by dragging 
items from the palette window, positioning and editing them as needed. 

Once you have finished the new dialog box, you can save it. Saving the dialog box will automatically 
cause the Dialog Window Type box to appear if you did not fill in the window's information 
previously. You can also use the Save As command to save the dialog box, but doing so will bring up 
the Dialog Window Type box regardless of whether the window's information was saved 
previously. 

You can close the dialog box at any time by clicking the close box or selecting Close from the 
File menu. (You will be prompted to Save if you try to Close the dialog box and have modified it 
since it was last saved.) 

The Report command offers a descriptive specifications list of the dialog box and its contents. 
Selecting Report brings up a dialog box from which you can select the report format-either text 
descriptions or MWS protocol commands (see Figure 1-16). 

• Figure 1-16 Report command dialog box 
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Selecting Textual Descriptions generates a window that describes the contents of the dialog box. 
Each item is listed separately, and described in terms of its size and attributes. The example in Figure 
1-17 shows a Textual Descriptions report for a dialog box containing a scrolling list and three radio 
buttons. 

• Figure 1-17 Textual Descriptions report 
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Selecting MWS protocol generates a window displaying the MWS commands necessary to create the 
dialog box and its contents. This protocol report can be copied to the Clipboard or saved as a text 
file for uploading to the host program, so that the host program can generate an identical dialog 
box. The example in Ftgure 1-18 shows an MWS protocol report for the same dialog bOx used in the 
previous example; it contains a scrolling list and three radio buttons. 

• Figure 1-18 MWS Protocol Commands report 
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The last command in the File menu, Quit, allows you to quit from Dialog Builder. 

The Edit menu 

You use the Edit menu to access editing operations when creating or modifying a dialog box (see 
Figure 1-19). 

• Figure 1-19 The Edit menu 
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Undo, Cut, and Copy are available only when a desk accessory is active; there are currently no 
facilities in Dialog Builder to support these commands. 
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Paste copies the contents of the dipboord and pastes them into the dialog box. Using Paste, 
you can open the Scrapbook, copy a graphic, then paste it into your dialog box. Clear removes all 
selected objects from the dialog box (as does selecting items and pressing the Delete key). 

6. Important Clear cannot be undone, since there is no Undo command available. 

Duplicate copies a selected item and places the copy in the dialog box. Select All selects every item in 
the dialog box. Remember, you can select multiple items by holding down the Shift key and clicking 
the items you want to select, or by dragging through multiple items. 

The Options menu 

The commands specific to Dialog Builder are contained in the Options menu (see Figure 1-20). 
Dialog Specs brings up the Dialog Window Type box, where you can change information such as the 
dialog box window type or name, resource name, or resource ID. The command Item Attributes 
functions the same as if you had double-clicked an item in the dialog box: its attributes window 
appears so you can specify certain characteristics for that item Remember that attributes vary 
depending on the type of dialog box item. 

• Figure 1-20 The Options menu 
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The Cluster command creates a group identifier for any currently selected objects. Uncluster breaks 
up a previously created cluster. Reorder renumbers the currently selected objects in the order you 
selected them. Align To Grid snaps the selected items to the invisible grid. 

Change Type brings up a dialog box in which you can change certain types of items to other 
types (see Figure 1-21). This command is functional only for buttons, check boxes, radio buttons, 
and static and edit text fields. 
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• Figure 1-21 The Change Type command dialog box 
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The Use Actual Window command allows you to edit the dialog box while it appears on the screen 
in its actual shape and its title shows in the title bar. This command is useful when you want to see 
how items will look with respect to the actual shape of the dialog box. By default, the dialog box 
shape is that of a rectangular window. Normally, dialog boxes and alerts use other standard shapes. 
Refer to the Human Inter/ace Guidelines for a complete discussion on window shapes and their 
usage. 
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